Victor Barzana
1 min readFeb 28, 2019

--

Nice Article Alberto, although I have a suggestion, I would call the job ‘job_name’ rather than ‘queue_name’ because that’s the actual name of the job, not the name of the queue.

To have a different queue we use prefixes, so we initialize kue like this:
```const queue = kue.createQueue({
prefix: ‘cron’, // to process all cron type of events for example
redis: ‘any redis url’ // if you are using any Redis server
});```

We use a very similar approach in the company I work for, the most important factor is to be able to have a completely stateless app.

Great post, thanks for sharing!

Victor

--

--

Victor Barzana
Victor Barzana

Written by Victor Barzana

Full Stack Senior Software Engineer

No responses yet